Access to the Dashboard maybe affected whilst your DNS updates.
Posted Jul 06, 2025 - 17:07 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 06, 2025 - 16:21 UTC
Scheduled
Sunday, 6th July at 5:30 PM (BST)
This upgrade is part of our ongoing commitment to keeping the platform even more resilient, scalable, and high-performing under heavy workloads, helping ensure smooth operation during peak activity.
Here's what to expect during the upgrade:
All flows will continue to trigger as normal. There will be a brief pause of up to one minute where flows may queue. No data will be lost — everything will resume automatically, with flows running from the correct timestamp once the update is complete.