The issue affecting the DeDupe and Track shapes has now been fully resolved, and all services are operating normally.
If you experience any further issues, please contact our Support Team via your usual support channels, and we will be happy to assist.
A full Root Cause Analysis (RCA) is now available for customers upon request.
Posted Dec 03, 2025 - 11:18 UTC
Identified
We are currently investigating an issue affecting the DeDupe and Track shapes, which may cause intermittent failures in flow execution.
At this time, data is not being lost, however some processes may be running slower than expected or retrying automatically while we work to resolve the underlying issue.
Our engineering team has identified the root cause and remediation is in progress. We are continuing to monitor the platform closely and will provide further updates as soon as more information is available.
Posted Dec 03, 2025 - 10:55 UTC
Update
We are continuing to investigate this issue.
Posted Dec 03, 2025 - 10:53 UTC
Investigating
We are currently investigating an issue with the Dedupe performance that will be slowing flows down
Posted Dec 03, 2025 - 09:32 UTC
This incident affected: Shapes (De-Dupe, Track Data).